Shared hosting maintenance
Incident Report for Fused
Resolved
Completed in full, have a great weekend!
Posted 6 months ago. Jan 06, 2018 - 05:01 UTC
Investigating
Performing shared hosting emergency maintenance, each system will return in 3-5 minutes.
Posted 6 months ago. Jan 06, 2018 - 04:44 UTC