Latency
Incident Report for Fused
Resolved
This incident has been resolved.
Posted 2 months ago. May 18, 2019 - 00:57 UTC
Monitoring
Seems everything has returned to normal, we'll communicate with our network vendors and continue monitoring the situation.

Thanks!
Posted 2 months ago. May 17, 2019 - 18:40 UTC
Investigating
Seeing increased latency, investigating.
Posted 2 months ago. May 17, 2019 - 18:36 UTC
This incident affected: Network.