Increased network latency
Incident Report for Fused
Resolved
Upstream provider was undergoing router maintenance. It is back to normal now.
Posted about 1 year ago. Mar 29, 2018 - 12:47 UTC
Monitoring
Please stand by while our upstream providers try to converge their networks.
Posted about 1 year ago. Mar 29, 2018 - 10:27 UTC