Some of Let's Encrypt certificates are now in kamikaze mode
Incident Report for Fused
Resolved
Let's Encrypt is throwing a party, they've settled down on quitting doing random things. They've made their mind up on all this certificate drama and out of those 3 million certificates they will be revoking only 2 million that they believe have already been renewed and will leave the remaining certs in peace util they expire on their own. Crisis averted.
Posted Mar 05, 2020 - 11:49 UTC
Identified
Just recently, our SSL certificate provider, Let's Encrypt, realized they've had enough sailing in smooth waters for the last 3 months and decided to find a bug in their code which eventually led them to a brilliant idea of revoking 3 million certificates they've issued earlier with less than 48 hours notice. 455 of those are of our clients.

This issue should self-resolve once certificates are revoked on their side and re-requested on ours. During the window between these events some sites might show a certificate invalid warning. For those users that wish to expedite the process, we suggest doing the following:

cPanel >> Security >> SSL/TLS -> Manage SSL Sites -> Delete the affected certificate
cPanel >> Security >> SSL/TLS Status -> Run AutoSSL

You can check if you're affected at https://checkhost.unboundtest.com/
Posted Mar 04, 2020 - 19:06 UTC
This incident affected: Shared Hosting (server 16, server 17, server 18, server 19, server 20, server 21, server 22, server 23, server 24, server 25, server 26, server 27, server 28, server 29, server 30, server 31).